$re = '/^(123|111)(?:_input|_output)?$/m';
$str = 'New folder
111_input
123
123_input
456_output
monitor - Copy - Copy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);