package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(123|111)(?:_input|_output)?$`)
var str = `New folder
111_input
123
123_input
456_output
monitor - Copy - Copy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}