re = /^(123|111)(?:_input|_output)?$/m
str = 'New folder
111_input
123
123_input
456_output
monitor - Copy - Copy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end