const regex = /^(123|111)(?:_input|_output)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(123|111)(?:_input|_output)?$', 'gm')
const str = `New folder
111_input
123
123_input
456_output
monitor - Copy - Copy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}