import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.)\\1{1,}$";
final String string = "john\n"
+ "wentt\n"
+ "to\n"
+ "tthe\n"
+ "moovies\n"
+ "wheree\n"
+ "he\n"
+ "abrupttly\n"
+ "pp\n"
+ "something\n"
+ "blah\n"
+ "===\n"
+ "--\n"
+ "2343\n"
+ "ajsdflja\n"
+ "aaa\n"
+ "dfs\n"
+ "aple\n"
+ "apple\n"
+ "pp\n"
+ "ppp\n"
+ "soomethings\n"
+ "please help me hello\n"
+ "hello\n"
+ "A\n"
+ "a\n"
+ "bb\n"
+ "B\n"
+ "b.\n"
+ "jslkdf kk\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}