$re = '/^(.)\1{1,}$/m';
$str = 'john
wentt
to
tthe
moovies
wheree
he
abrupttly
pp
something
blah
===
--
2343
ajsdflja
aaa
dfs
aple
apple
pp
ppp
soomethings
please help me hello
hello
A
a
bb
B
b.
jslkdf kk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);