re = /^(.)\1{1,}$/m
str = 'john
wentt
to
tthe
moovies
wheree
he
abrupttly
pp
something
blah
===
--
2343
ajsdflja
aaa
dfs
aple
apple
pp
ppp
soomethings
please help me hello
hello
A
a
bb
B
b.
jslkdf kk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end