# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)px/.$1rem/gm;t' <<< "width:203px
top:46px
top:6px"