$re = '/(\d)px/m';
$str = 'width:203px
top:46px
top:6px';
$subst = ".$1rem";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;