// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d)px").unwrap();
let string = "width:203px
top:46px
top:6px";
let substitution = ".$1rem";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}