import Foundation
let pattern = #"(\d)px"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
width:203px
top:46px
top:6px
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".$1rem"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)