using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(1?)(\s?)([\s]?)((\(\d{3}\))|(\d{3}))([\s]?)([\s-]?)(\d{3})([\s-]?)(\d{4})+$)";
string input = @"555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
1 555 555 5555
800-692-7753
6505552368
-1 (757) 622-7382
555)-555-5555
(555-555-5555
1 (555) 555-5555
8oo-six427676;laskdjf";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}