import re
regex = re.compile(r"(^(1?)(\s?)([\s]?)((\(\d{3}\))|(\d{3}))([\s]?)([\s-]?)(\d{3})([\s-]?)(\d{4})+$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("555-555-5555\n\n"
"(555)555-5555\n\n"
"(555) 555-5555\n\n"
"555 555 5555\n\n"
"1 555 555 5555\n\n"
"800-692-7753\n\n"
"6505552368\n\n"
"-1 (757) 622-7382\n\n"
"555)-555-5555\n\n"
"(555-555-5555\n\n"
"1 (555) 555-5555\n\n"
"8oo-six427676;laskdjf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")