// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(^(1?)(\s?)([\s]?)((\(\d{3}\))|(\d{3}))([\s]?)([\s-]?)(\d{3})([\s-]?)(\d{4})+$)").unwrap();
let string = "555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
1 555 555 5555
800-692-7753
6505552368
-1 (757) 622-7382
555)-555-5555
(555-555-5555
1 (555) 555-5555
8oo-six427676;laskdjf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}