const regex = /\W+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W+', 'gm')
const str = `feature/my-feature-1130`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);