#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\[[^|\n]*(?:\|[^|\n]*){3,}]$"
Local $sString = "[keyword1|keyword2|keyword3]" & @CRLF & _
"[keyword1|keyword2]" & @CRLF & _
"[keyword1|keyword2|keyword3|keyword4]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)