package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[[^|\n]*(?:\|[^|\n]*){3,}]$`)
var str = `[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3|keyword4]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}