use strict;
my $str = '[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3|keyword4]';
my $regex = qr/^\[[^|\n]*(?:\|[^|\n]*){3,}]$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";