// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[[^|\n]*(?:\|[^|\n]*){3,}]$").unwrap();
let string = "[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3|keyword4]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}