import Foundation
let pattern = #"^\[[^|\n]*(?:\|[^|\n]*){3,}]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[keyword1|keyword2|keyword3]
[keyword1|keyword2]
[keyword1|keyword2|keyword3|keyword4]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)