#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|\n)\d+\s*people:([\s\S]*?)(?=\n{3}|$)"
Local $sString = "2 people:" & @CRLF & _
"Juan" & @CRLF & _
"Gabriella" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3 people:" & @CRLF & _
"Foo" & @CRLF & _
"Bar" & @CRLF & _
"Bazz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")