import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\n)\\d+\\s*people:([\\s\\S]*?)(?=\\n{3}|$)";
final String string = "2 people:\n"
+ "Juan\n"
+ "Gabriella\n\n\n"
+ "3 people:\n"
+ "Foo\n"
+ "Bar\n"
+ "Bazz";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}