const regex = /(?:^|\n)\d+\s*people:([\s\S]*?)(?=\n{3}|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\n)\\d+\\s*people:([\\s\\S]*?)(?=\\n{3}|$)', 'g')
const str = `2 people:
Juan
Gabriella
3 people:
Foo
Bar
Bazz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}