$re = '/(?:^|\n)\d+\s*people:([\s\S]*?)(?=\n{3}|$)/';
$str = '2 people:
Juan
Gabriella
3 people:
Foo
Bar
Bazz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);