re = /(?:^|\n)\d+\s*people:([\s\S]*?)(?=\n{3}|$)/
str = '2 people:
Juan
Gabriella
3 people:
Foo
Bar
Bazz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end