#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:[ra]s|s[ar]|[ars])\b"
Local $sString = "rs" & @CRLF & _
"sr" & @CRLF & _
"as" & @CRLF & _
"sa" & @CRLF & _
"a" & @CRLF & _
"r" & @CRLF & _
"s" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ra - ar" & @CRLF & _
"asr - ars - sra - sar - rsa - ras "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")