import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[ra]s|s[ar]|[ars])\\b";
final String string = "rs\n"
+ "sr\n"
+ "as\n"
+ "sa\n"
+ "a\n"
+ "r\n"
+ "s\n\n\n"
+ "ra - ar\n"
+ "asr - ars - sra - sar - rsa - ras ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}