package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[ra]s|s[ar]|[ars])\b`)
var str = `rs
sr
as
sa
a
r
s
ra - ar
asr - ars - sra - sar - rsa - ras `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}