$re = '/\b(?:[ra]s|s[ar]|[ars])\b/m';
$str = 'rs
sr
as
sa
a
r
s
ra - ar
asr - ars - sra - sar - rsa - ras ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);