using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[ra]s|s[ar]|[ars])\b";
string input = @"rs
sr
as
sa
a
r
s
ra - ar
asr - ars - sra - sar - rsa - ras ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}