use strict;
my $str = 'January
February
March';
my $regex = qr/\b\w{3}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";