# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<form[^>]*>((?!<\\/form>).)*<\\/form>//gim;t' <<< "<p>Hey I am a boy</p>
<form id='id1' class='class1'>Content</form>
<p>Hey I am a girl</p>
<form id='id1' class='class1'>content</form>"