re = /<form[^>]*>((?!<\/form>).)*<\/form>/im
str = '<p>Hey I am a boy</p>
<form id=\'id1\' class=\'class1\'>Content</form>
<p>Hey I am a girl</p>
<form id=\'id1\' class=\'class1\'>content</form>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result