#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(circuit\sId\s\W(\w+))|(circuit\sid\s\W(\w+))"
Local $sString = "OUT 01/10/18 16:54:51 - 1104709952: Successfully setup db-only network connection <circuit_id>gtwsti<\circuit_id> port on 'swsedfhwsehf', input parameters (logical port 'edgvseurgy', BGW circuit id 'abcdef', circuit Id =gtwsti " & @CRLF & _
"zsjgvhdkligb" & @CRLF & _
"sdigdlogb" & @CRLF & _
"okw2124e242 dxlchbjdx" & @CRLF & _
"COMS circuit Id :sftwegft', NoOption business type, access point 2, VLANService, UnspecifiedAccessType access type, NNI port type, additional params ( 'reservationSessionId'='PC:1515603258773' 'lportAccessType'='ETH100' 'additionalLports'='7465754757fchdjgj' )', request mode 'Ignore', for user <circuit_id>gtwsti<\circuit_id> 'PC:517423453275'xx_PROTECTED_xx dg" & @CRLF & _
"wfgtrwukftw"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")