import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(circuit\\sId\\s\\W(\\w+))|(circuit\\sid\\s\\W(\\w+))";
final String string = "OUT 01/10/18 16:54:51 - 1104709952: Successfully setup db-only network connection <circuit_id>gtwsti<\\circuit_id> port on 'swsedfhwsehf', input parameters (logical port 'edgvseurgy', BGW circuit id 'abcdef', circuit Id =gtwsti \n"
+ "zsjgvhdkligb\n"
+ "sdigdlogb\n"
+ "okw2124e242 dxlchbjdx\n"
+ "COMS circuit Id :sftwegft', NoOption business type, access point 2, VLANService, UnspecifiedAccessType access type, NNI port type, additional params ( 'reservationSessionId'='PC:1515603258773' 'lportAccessType'='ETH100' 'additionalLports'='7465754757fchdjgj' )', request mode 'Ignore', for user <circuit_id>gtwsti<\\circuit_id> 'PC:517423453275'xx_PROTECTED_xx dg\n"
+ "wfgtrwukftw";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}