// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(circuit\sId\s\W(\w+))|(circuit\sid\s\W(\w+))").unwrap();
let string = "OUT 01/10/18 16:54:51 - 1104709952: Successfully setup db-only network connection <circuit_id>gtwsti<\\circuit_id> port on 'swsedfhwsehf', input parameters (logical port 'edgvseurgy', BGW circuit id 'abcdef', circuit Id =gtwsti
zsjgvhdkligb
sdigdlogb
okw2124e242 dxlchbjdx
COMS circuit Id :sftwegft', NoOption business type, access point 2, VLANService, UnspecifiedAccessType access type, NNI port type, additional params ( 'reservationSessionId'='PC:1515603258773' 'lportAccessType'='ETH100' 'additionalLports'='7465754757fchdjgj' )', request mode 'Ignore', for user <circuit_id>gtwsti<\\circuit_id> 'PC:517423453275'xx_PROTECTED_xx dg
wfgtrwukftw";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}