const regex = /(circuit\sId\s\W(\w+))|(circuit\sid\s\W(\w+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(circuit\\sId\\s\\W(\\w+))|(circuit\\sid\\s\\W(\\w+))', 'g')
const str = `OUT 01/10/18 16:54:51 - 1104709952: Successfully setup db-only network connection <circuit_id>gtwsti<\\circuit_id> port on 'swsedfhwsehf', input parameters (logical port 'edgvseurgy', BGW circuit id 'abcdef', circuit Id =gtwsti
zsjgvhdkligb
sdigdlogb
okw2124e242 dxlchbjdx
COMS circuit Id :sftwegft', NoOption business type, access point 2, VLANService, UnspecifiedAccessType access type, NNI port type, additional params ( 'reservationSessionId'='PC:1515603258773' 'lportAccessType'='ETH100' 'additionalLports'='7465754757fchdjgj' )', request mode 'Ignore', for user <circuit_id>gtwsti<\\circuit_id> 'PC:517423453275'xx_PROTECTED_xx dg
wfgtrwukftw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}