use strict;
my $str = 'OUT 01/10/18 16:54:51 - 1104709952: Successfully setup db-only network connection <circuit_id>gtwsti<\\circuit_id> port on \'swsedfhwsehf\', input parameters (logical port \'edgvseurgy\', BGW circuit id \'abcdef\', circuit Id =gtwsti
zsjgvhdkligb
sdigdlogb
okw2124e242 dxlchbjdx
COMS circuit Id :sftwegft\', NoOption business type, access point 2, VLANService, UnspecifiedAccessType access type, NNI port type, additional params ( \'reservationSessionId\'=\'PC:1515603258773\' \'lportAccessType\'=\'ETH100\' \'additionalLports\'=\'7465754757fchdjgj\' )\', request mode \'Ignore\', for user <circuit_id>gtwsti<\\circuit_id> \'PC:517423453275\'xx_PROTECTED_xx dg
wfgtrwukftw';
my $regex = qr/(circuit\sId\s\W(\w+))|(circuit\sid\s\W(\w+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}