#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\K(?:((?(1)\1)1).*?)*(?1)"
Local $sString = "01" & @CRLF & _
"1001111" & @CRLF & _
"010011111" & @CRLF & _
"0100111110001110" & @CRLF & _
"0100111011001110" & @CRLF & _
"0100111110011110"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")