$re = '/^.*?\K(?:((?(1)\1)1).*?)*(?1)/m';
$str = '01
1001111
010011111
0100111110001110
0100111011001110
0100111110011110';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);