const regex = /^.*?\K(?:((?(1)\1)1).*?)*(?1)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\K(?:((?(1)\\1)1).*?)*(?1)', 'mg')
const str = `01
1001111
010011111
0100111110001110
0100111011001110
0100111110011110`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}