import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\K(?:((?(1)\\1)1).*?)*(?1)";
final String string = "01\n"
+ "1001111\n"
+ "010011111\n"
+ "0100111110001110\n"
+ "0100111011001110\n"
+ "0100111110011110";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}