using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\K(?:((?(1)\1)1).*?)*(?1)";
string input = @"01
1001111
010011111
0100111110001110
0100111011001110
0100111110011110";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}