using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!boolean visible = false).)+$";
string substitution = @"";
string input = @"type dw_3 from u_dw within w_pg6p0012_01";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}