$re = '/^((?!boolean visible = false).)+$/';
$str = 'type dw_3 from u_dw within w_pg6p0012_01';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;