import re
regex = re.compile(r"^((?!boolean visible = false).)+$")
test_str = "type dw_3 from u_dw within w_pg6p0012_01"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)