import Foundation
let pattern = #"^((?!boolean visible = false).)+$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"type dw_3 from u_dw within w_pg6p0012_01"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)