using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n+^(I )?hope (it|this|that) helps?(\s|:-?\)|[!.])*$";
string substitution = @"";
string input = @"Just make a simple casting type:
```
x[0] = [x[0]]
x[0].append(...)
```
This will work as your expectation.
Hope this helps..";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}