package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\n+^(I )?hope (it|this|that) helps?(\s|:-?\)|[!.])*$`)
var str = `Just make a simple casting type:
\`\`\`
x[0] = [x[0]]
x[0].append(...)
\`\`\`
This will work as your expectation.
Hope this helps..`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}