import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n+^(I )?hope (it|this|that) helps?(\\s|:-?\\)|[!.])*$";
final String string = "Just make a simple casting type:\n"
+ "```\n"
+ "x[0] = [x[0]]\n"
+ "x[0].append(...)\n\n"
+ "```\n"
+ "This will work as your expectation.\n\n"
+ "Hope this helps..";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}